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Topic: SignCAD Basics

SignCAD is a stand alone program with smart objects that allow you to design highway signs.
Smart objects that are available through SignCAD are route markers, panels, symbols, arrows,
text, rectangles, and lines. SignCAD has a DynArrange Engine, so every time you add, modify
or remove an object, the size and dimensions of the panels are dynamically updated.

SignCAD supports state and federal standards for traffic signs; customization is available for
fonts, characters, symbols and objects.

Start SignCAD by double clicking the SignCAD Icon found on your desktop.

:i.__:|-L L
Be patient, it will take a few seconds to start the program.
If the server licenses are unavailable, the following message will appear:

AN CEnsing) d]

W aiting for an available network, licenze. You are the first person
waiting.,
SignCAD will autaratically start when one becomes available.

| Cancel | Help

If a SignCAD license is available then the New File dialog will appear as shown below. Select

the unit for your file and the standard you want to use. Scroll down to select Federal or state

standards. Select OK.

=7 Fil= l
Urits OF Measure Standard Note: Some tools are not available

in some of the state standards.
| j |L|.S. %partment af Tranzporkatian j

[ o ] IIIKFI::rf-‘nII| Help

A blank workspace will appear for you to design your sign.
Preferences

When signs are a created a default preference file is used. Preference file can be modified and
saved to a sign file. Preferences can be accessed from the main SignCAD selection tool.
Preferences for an object can be changed by selecting the object and changing the preference
at anytime.
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Shown below are the preference options:

Favorites ‘Window Help

Hide Ruler * Togygle onfoff for ruler
Drawing. .. F4 —— Invoke dialog box for outline mode
. and object data/dimension
Fill Color
Chbject Align r
Object Spacing... CTRL+] =" Muodify spacing around ohject
Texk Size... CTRL+5 —— Choose standand text size
Text Font... CTRL+F —— Choose standard highwy font
Texk Align »
&llow Panel Selection (CTRL)  ——= Toggle on/off for editing objects
Line ‘Width. .. CTRLAW e MO dify line width
Mekric {rmm)
Standard % ¥ English (decimal inch) —* Set unit

e Hide Ruler - Turn on/off the ruler for your workspace (drawing plane).

e Select F4 or Preferences>Drawing to invoke the following dialog box which can be
used to toggle outline mode (b/w or color) and object data/dimension mode:

[ Lzl St gls [31

[niclude:
[ Outline mode (black and white] T Letter autlining W Dimensions W Obiject list

BiErstis v Last dimenzion W Letter and Object Lefts

v Display dimensions Toitae W e
Drawing scale 1: |2|:| Decimal places |4

| Round lengths to nearest eighth inch

ok | Cancel | Help | Letter and Object Leftz Method;

* Bazeline values on panel %
" Baseling values in table
" Widths and spaces in table

" Distance between lefts in table

kK. | Cancel Help

Toggle on Display dimensions to see the dimension of your sign while designing.
Dimensions displayed will be what is selected in the Dimensions Style dialog box.

o Select Preferences>Fill Color to select the fill color of the smart objects (text, lines,
arrows, panel borders, etc.).
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Favarites  window  Help

Hide Ruler
Drawing. .. F4
Fill Colar r Black,
Chject Align » Bille = =
Chject Spacing. .. CTRL+I Birown

) Green
Text Size... CTRL+S

Qrange ik

Text Fonk... CTRL+F

i Red
Texk Align 3
Allows Panel Selection (CTRL) Yellow @
Line ‘idth. .. CTRL+W Yellow Green
Inits af Measure 3 Mone
Standard r I e =

Select the Object Align to align multiple objects in a panel.

S =s Y Favoribes  Window Help

Hide Ruler
Drawing... F4
Fill Calar *
Cbject align Left  CTRL+L
Object Spacing...  CTRL+I m

, Right CTRL+R g
Texk Size... CTRL+5
Texk Fonk,.. CTRL+F Top CTRL+T
Text Align H| w Middle CTRL4+D

: Eottaorn CTRL4E

allow Panel Selection (CTRL)
Line Width, .. CTRL+W
Inits of Measure b
Standard b

Object Spacing or CTRL+I to set the minimum distance an object can get to an
adjacent object or panel border.

Text Size or CTRL+S can be used to set the size of text. Choose from a list of standard
text sizes.

Text Font or CTRL+F can be used to set the font of text. Choose from a list of standard
highway fonts.

Use Text Align to align different sizes of text (similar to setting justification) within the
panel.

Allow Panel Selection toggled on will allow selecting and moving the panel around in
the workspace and copy to the clipboard (cut/paste between .sgn files). If turned off, use
CNTRL key and left mouse to move and edit the panel.
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e Line Width or CTRL+W can be used to set the width of the Line Tools (Horizontal,
Vertical or Arbitrary). ':'| D |%|

e Unit of Measure can be toggled to set English or Metric units.

Favorites  Window  Help

Hide Ruler
Drawing... F4
Fill Calar k
Object Align r
Ohbject Spacing. .. CTRL+I
Texk Size... CTRL+5S
Text Fank... CTRL+F
Text Align »
Allow Panel Selection (CTRL) | New. File
Line Width. .. CTRL+W
Units of Measure b Unitz OF Measure Standard
| j |U.S. Department of Tranzportation j
—
o] ok | okForal | Help

o |f Standard>New File Prompting>on is checked, then when opening a new file, a
dialog box will appear allowing you to select units of measure and standard. If you
select OK for all then the new file prompting will get turned off for the session.

Objects and selection tools

Shown below are icons for objects and selection tools. These objects and tools can be used to
create and change sign objects.

L SSiBnGADSimtited iy

By File Edit Tools View Preferences Favorites Window Help

s = 13001 ¢ T2 [=bl el 7| v o | 9|0 @O @@ oloe
J L L
SEIElﬂLineﬂsﬂEngles j B S — —Route Markers | _ Pane’:;’a“ge
Symbol —

Tools are also available through the pulldown menu:

@ Wiew  Preferences
Select

Line L ‘
Rectangle E
Riounded Rectangle
Symbal

Texk

Arrom 3
Route Marker »
Panel »
Arrange
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Select an object and place point on the screen. The dialog box associated with the
object will appear allowing the user to enter or select parameters for the object. Shown
below is a dialog box for a Down Arrow.

Linyyan) siruys G

Angle | Size |22 _:J

Location: |1ED i |55

] . Cancel | Help
3

Selecting OK will create the object on the screen. Right clicking on an object and
selecting Edit Data will allow the user to edit the parameters of an object at any time.

An object placed on the screen can be removed by using the Select icon and clicking
the delete button on the keyboard or use Edit>Delete.

To place lines and rectangles, select the tool, select a point on the screen, drag and
drop opposite corners. Panels will automatically adjust to fit the lines and rectangles.

=l 0/8) o]0

Lines s |
Rectangles

To add text, select the text tool, select a point on the screen and type the desired text.
Text size, font and alignment can be adjusted by right clicking on the text and selecting
from the options (text size, text font or text align).

k= 0[] 0] 0] $JT]% |||l &

Text

Use Standard Sign Panel to layout fixed size signs of varying shapes. The size of the
panel will not be adjusted automatically. Use Rectangular Panel to layout any signs.
The size of the panel will adjust automatically as objects are added or removed.

ool
Standard Sign Panel

Rectangular Sign Panel

The arrange button can be used to arrange objects in rows, columns or tabular
arrangement. Tabular arrangement arranges objects in both rows and columns.

DEI

]
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e To modify an object right click to access the floating menu or edit data. Select and
double click on an object to invoke the properties dialog box.

g ™

Edit Data

Fill Calor »
e Obiject Align » Left
- Object Spacing... v Center
] Right
Text Size...
Text Font., ., Top
v Middle

Floating Menu Bottom

In SignCAD, multiple (*.sgn) file can be opened at one time. See Window pulldown for window
arrangement options.

See Edit pulldown for copy/cut/paste/delete options available in SignCAD.
See View pulldown for zoom options available in SignCAD.
A sign developed with SignCAD can be placed into MicroStation as a dgn element or as a cell.

SignCAD Menu in MicroStation:

Open a MicroStation file. SignCAD MDL is automatically loaded with MicroStation. SignCAD
Menu is available through MicroStation as shown below:

Applications  MWindow  Help

GECPAEK r
GEOPAK ERIDGE b
GEOPAK DRAIMAGEE b
GEOPAK LANDSCAPE b
GEOPAK ROAD b
GEQPAK SITE r
GECPAE SURYEY » Open SignCAD File
GEOPAK WATER SEWER. b OR select the Place SignCAD File
Cpen Sign File -TOOI Box to Run SignCAD
invoke a
Place Sign File dockable E
£HN SignCAD = &l s I

[EEEETRT  dialog box.
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If the Tool Box is selected and docked, for future MicroStation sessions SignCAD Tool Box will
automatically be loaded.

Using the MicroStation SignCAD Menu:

Open Sign file - Opens the sign file (*.SGN) from a file list and places the sign into a
new MicroStation DGN file. User can select the MicroStation seed file. Saves the file in
.DGN format.

Place Sign file - Selects the sign file (*.SGN) from a file list and places the sign as .DGN
format file to the current MicroStation file

Run SignCAD - Opens the SignCAD program from MicroStation.

=l

Display Tool Box - To place a dockable SignCAD toolbar.

Selecting Place Sign File will invoke the following dialog box:

= SENEAI I B eSS e lIngs J _Ja‘
{Rotatation dngles [

Ak

Geomety Scale: | 1.00

Master Unitz:  fest i

E l ] Geometry Level: |1
Fil=  Directory Dimension Lewvel: |1
Files: Directaries: W Include dimensions
[ - ASignCaDtSignshs amplesh I:I ¥ Color fl
Alinpanl. san -] L Dimension Sizing:
Alingamp. zgn :‘ [ Program Files Lancel @ . J .
A rnarilla. sgn [ SignCAD Use SignCAD size
Arrange. zan [ Signs ' Specify drawing scale
Arranged.sgn = Samples
Ao, sgh >
stin, sgn ) Specify final text size
Colors. zgn li
Dirnztyle. zgn
Exporthp.zgn j
List Files of Type: Dirives: oK Cancel
SignCAD Sign File [£.SGM] | -] = Q

Select your file and select Settings button to modify initial settings for scale, color or dimension
display. Select OK twice to place the file into MicroStation.

kmsiimg g 99 L1064 4

Color Fill turned on
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GRAND CANYON il

® 3
’-—10.;.J ws s34 499 4 10.8-1\ )
120 Color Fill turned off

1
A\ If the color fill is turned on when sign is placed into a MicroStation drawing, the sign will print
all black.

MicroStation level D_Dimensions will be used when sign is placed into a MicroStation file. Sign
information should be moved to the proposed sign level P_TC_Signs_Permanent.

Another way to place a sign file into MicroStation is using the edit and paste commands.

Using Edit/Paste command:

Open a MicroStation file and the SignCAD file. Select sign in SignCAD file and select
Edit>Copy, Go to MicroStation file and Select Edit>Paste>Sign. Allow Panel Selection must
be toggled on to copy to clipboard. The .sgn file will placed as cell.

Workflow #1 — Creating a Distance Sign

This example will create a sign with 3 rows of object that will be left aligned.

1. Select the Rectangular panel tool from the tool bar and data point on the screen to invoke
the Rectangular Panel dialog box:

I [=] DS][ 0]O] ¢ | T] [ =>{eo] el ]| | @] @Ol @] O @] @ ||

REE NP I E ] _Jﬂll

2. Select Guide Sign from the General

General l Size ] Bl:url:ler] L-:u:aticun] Spacing] Eustl:lm] Tab. Go t‘? the Border_ Tab and .
. %e uncheck Size automatically. Width,
Sign type Plagel color Radius and Indent will be un-grayed
| v| |Gieen ]| allowing the user to input the values.
[ dentifier
| REGITaarmel J\E
Auto Defaults Template: Generall Sie  Border l Locatiunl Spacing} Eusluml
<Mane> vl Create | One barder M
[ Trim comers ¥ Change ling width
Widh  Radus Indent  Border color

ak. | Cancel | Help | |1 |3 |EI ‘While j
Cuisharm I

3. Select OK to invoke a blank Panel

8 Cancel Help
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1 Note: Click on Trim corners in the border tab above to
show panel with only rounded corners.

07

4. Select the Arrange tool from the tool bar.
Select a point on the screen with the left mouse to
invoke the Arrangement dialog box shown below:

oo
e
';Errungamam
Type: Size:
" Row Colurmns ﬂ

 Column
LL _J_: o Tabular Fowvus ﬁ

. 36 ]
3.0" Radius, 1.0" Border, White on Grean; | 0K I Cancel | Help |

5. Select number of columns to two and
rows to three by entering or scrolling.
Select OK.

6. Pick the Select tool 7 I52lect and select an edge (not a corner) of the arrangement box. A drag
hand will appear.

7. Drag the box into the panel and when the blinking rectangle appears in the
panel release the mouse button. Dashed blue lines show alignments of
objects and are visible only when the arrange tool is picked.

{7

1 4}|~‘~{}?| I:§>|<%‘>|ﬁ>| ﬂlfbl%’l $|' 8. Select the text icon and move the cursor around on the
panel. Blinking rectangles appear in different locations
as the cursor is moved over the panel.

9. Press the left mouse button and select upper left cell of
the tabular arrangement.

L

b 12 *J
20" Radius, 1.0" Border, White on Greesn
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R 10. To select the Text size, use Preference Menu or
: Press <Ctrl> S and pick 6” from the size list. Press
Size
- OK.
G =
Standard:
g a {* Standard
10 .
10.6ERT  Overiden
12
132333 &
Cancel | Help
axt Font 11. To select the Font, Press <Ctrl> F and pick D from

the series list. Press OK.

B
C
E
F
ok Cancel Help |

A

12. Type the following text (turn on the
caps lock): “RICQO” >Enter
“CORTEZ" >Enter
“DURANGOQ” >Enter.

The panel will adjust size to
accommodate the entered text.

RICO
CORTEZ
DURANGO

17.1
13.3— sk 26 5 3k 173
a7

L 7k 5 skandk 5 kandk gk 75
42

—9.5

&80
2.0" Radius, 1.0" Border, White on Green;

"RICO" D; *CORTEZ" D; *DURANGO" D;

-10 -
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RICO 20
CORTEZ 15
DURANGO 60

b

A

k75— —kask ks sk 5k 75
42

13. Tab to the second column and Type
“20”" > Enter
“15” > Enter

“60” > Enter.

17.1
295 14
5.9 sk —sk

19.5— sk
o9k

72
2.0" Radius, 1.0" Barder, White on Green;

"RICO" D; "20" D; "CORTEZ" D; 158" D; "DURANGO" D; "80" D;

a
14. Select the Arrange tool D_land double click on one of the dashed lines to invoke the

Tabular Arrangement dialog box.

2]x]|

PRI TR AT EE N 15.
Minirmun Size I hinimun Space | Lines |
Size | Pow dlignments Calumn Alignments
Colurmn Murnber I E
frarm left i
@ Left  © Cemter ¢ Right
| 0K, I Cancel Help |
| E3)
16.
Size I R Alignments | Colurmn Alilgnments
Minimum Size Minimurn Space Lines
Top
|2
Lett Right
|z 4-}) [z
Baottarn
|2
| Ok | Cancel Help I

-11 -

Select the column Alignments tab and enter
left alignment for column 1, scroll and select
Left alignment for column 2.  This will left
justify all the text.

Select Minimum Space tab and set all the fields to
2 (minimize). Minimum spacing and object spacing
controls the spacing between objects in a tabular
arrangement. The larger of the 2 values control.
Select OK.

In tabular arrangement minimum space is the
minimum distance between one object to the
adjacent object, set minimum spacing so it does
not control. Object spacing should control in a
tabular arrangement.
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17.  Pick the Select tool ~~ I5#lect and window select the panel (click on one corner, hold and
drag mouse to opposite corner). The objects in panel will have handles as shown below:

e

RICO
CORTEZ

s

18. Select Preferences > Object Spacing. Distance between objects vertically and horizontally
are controlled by the Object Spacing values. Enter 3.5 in the fields for top and bottom
spacing and 4 for left and right spacing. Select OK.

Hide Ruler

Drawing... F4 I ECLSPEETE)
Fill Colar 4 T
Ohject Align 4 i

Object Spacing... | CTR |3.5
Text Size.., _TRL+5 Left Right
Text Fontk... CTRL+F |4— M— Simple |

Text Align L Bottam

Allow Panel Selection (CTRL) |3.5

Line ‘Width... CTRL+WY

Units of Measure r | 0K I Cancel | Halp |
Standard k

A\ if Allow Panel Selection is toggled on Object Spacing will be grayed out.

-12 -
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RICO 20

CORTEZ 15

DURANGO 60

95..-54%8@6@—6%:5%

36

7.0k 7.4 k 238 k—g4—k 78—
—7.9—k 205 114 —sk65—+—10.3—
k—7.9—k 389 Eah 04—k 78

€6
3.0 Radius, 1.0" Border, White on Green;

“RICOY D; "20° Oy "CORTEZ D; “18" D) "DURAMNGT [y "60” D

19. Right click on the middle line and select object spacing from the preference menu. Set

the top and bottom spacing to 4.5".

r

Edit Data

Fill Color
Object Align
(s

Texk Size...
Text Font...
Text Align

7.0k
7.0k 295 e 114—h—6.9—k
k70— 369 gk g4

56
3.0" Radius, 1.0" Border, White on Gresn;

"RICC D; "20" Oy “CORTEZ D; "1 D; "DURANGC D "60" D;

?ULIJE’JI S ACINE

Top
Left $ Right
Id_ |4— Simple |
Bottaom
ok - I Cancel | Help |

Left and right spacing can be adjusted by assigning a value larger than 4” between object.

$Tips

e Signs created using a SignCAD can be saved into a library for future use. Special signs

developed for a project should be placed on N:\Programs\Signs\cflsamples.

e Double clicking on a .sgn file in windows explorer will open up the sign file in the

SignCAD program.

« State and Federal SignCAD library can be accessed by selecting File>Open>Standard

Sign. Files are located in C:\Program Files\SignCAD\Signs\Standard

Related links: SignCAD by SignCAD Systems Inc. Information contained in this handout is taken from the

SignCAD help file.

-13 -



	SignCAD is a stand alone program with smart objects that allow you to design highway signs.  Smart objects that are available through SignCAD are route markers, panels, symbols, arrows, text, rectangles, and lines.  SignCAD has a DynArrange Engine, so every time you add, modify or remove an object, the size and dimensions of the panels are dynamically updated. 
	SignCAD supports state and federal standards for traffic signs; customization is available for fonts, characters, symbols and objects. 
	Start SignCAD by double clicking the SignCAD Icon found on your desktop.   
	   
	Be patient, it will take a few seconds to start the program.  
	If the server licenses are unavailable, the following message will appear: 
	  
	If a SignCAD license is available then the New File dialog will appear as shown below.  Select the unit for your file and the standard you want to use.  Scroll down to select Federal or state standards.     Select OK. 
	  
	A blank workspace will appear for you to design your sign. 
	In SignCAD, multiple (*.sgn) file can be opened at one time.  See Window pulldown for window arrangement options. 
	See Edit pulldown for copy/cut/paste/delete options available in SignCAD. 
	See View pulldown for zoom options available in SignCAD. 
	A sign developed with SignCAD can be placed into MicroStation as a dgn element or as a cell.  
	SignCAD Menu in MicroStation: 
	Open a MicroStation file.  SignCAD MDL is automatically loaded with MicroStation.  SignCAD Menu is available through MicroStation as shown below: 
	     Color Fill turned on  
	  Color Fill turned off 
	 If the color fill is turned on when sign is placed into a MicroStation drawing, the sign will print all black. 
	MicroStation level D_Dimensions will be used when sign is placed into a MicroStation file.  Sign information should be moved to the proposed sign level P_TC_Signs_Permanent. 
	Another way to place a sign file into MicroStation is using the edit and paste commands.   

