
CADD REHERSALS ANYTIME-WITH MICROSTATION&GEOPAK (CRAM) 
CRAM #38 – Google Earth Images 

4/16/2012 

 - 1 - 

 

Table of Contents 
CRAM 38:  MICROSTATION AND GOOGLE EARTH IMAGES - 2 - 

How to Import and work with Google Earth Images within MicroStation V8i - 2 - 
Introduction and Summary: - 2 - 
Basic Set-up and Steps: - 2 - 
Overview and Features: - 3 - 
Hints, Tips & Tricks: - 4 - 

SAMPLE  PROCEDURE (1) - IMPORTING GOOGLE EARTH IMAGES IN 2D OR 3D - 5 - 
Preliminary Steps.............................................................................................. - 5 - 
Procedure Steps ............................................................................................... - 6 - 

1. Select and set the Geographic Coordinate System: - 6 - 
2. Google Earth Steps – Image Settings: - 8 - 
3. MicroStation Import Steps - Follow and “Capture” the image from Google Earth: - 8 - 
4. Additional MicroStation Steps, Settings and Sheet Finalization: - 9 - 

 



CADD REHERSALS ANYTIME-WITH MICROSTATION&GEOPAK (CRAM) 
CRAM #38 – Google Earth Images 

4/16/2012 

 - 2 - 

CRAM 38:  MicroStation and Google Earth Images 

How to Import and work with Google Earth Images within MicroStation V8i 
Introduction and Summary: 
 
The Google Earth is an application that can be combined with MicroStation to import images for FLH roadway 
design or plan production.  As MicroStation has advanced, using an image for a project has become easier.  This 
document will provide some guidance on the software needs, basic steps, tips & tricks, and some procedures for 
the use of Google Earth within MicroStation. 
 
It is possible to view a Google Earth image in 3D and to display the Google Earth surface or terrain model.  To 
do this, the import process must be done in a 3D MicroStation file. 
 
It is strongly noted that any professional production, publication, or exhibit using Google Earth must 
have a Google Earth trademark representation within it.  This could be a logo or reference of the 
software used. 

 

Basic Set-up and Steps: 
Needed files/software:  Before the process of importing Google Earth Images is started, verify the following 
files and/or software is available. 

• Google Earth application is installed (Pro or basic version) 
• MicroStation V8i or newer version 
• MicroStation file (.dgn) is created (2D or 3D based upon desired results) 
• Note that GEOPAK is not needed for this process 

 
Simplified Process:  Below are the summarized basic steps. 

• Create a MicroStation file and set up coordinate system 
• Use Google Earth to capture the desired image area 
• Create and import the Google Earth Image 
• Apply settings and post importing manipulations 
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Overview and Features: 

Geographics Toolbox 
The Geographics Toolbox and/or tools are accessed through the MicroStation Main Menu by selecting 
Tools>Geographic. 
 

 

The Geographics Toolbox contains tools for interacting with a Global Positioning System (GPS) or Google 
Earth. Included are tools for: 

• Selecting a geographic coordinate system. 
• Accessing a GPS. 
• Defining a Google Earth placemark location in a MicroStation model. 
• Placing models in Google Earth. 
• Capturing a Google Earth image. 
• Matching the viewing location in MicroStation to that in Google Earth, and vice-versa. 
• Playing a MicroStation camera animation in Google Earth. 

 

Select Geographic Coordinate System 
The Select Geographic Coordinate System opens the Geographic Coordinate System dialog, which is used to 
select a geographic coordinate system (GCS) from a library of predefined geographic coordinate systems. 

 

Key-in: GEOCOORDINATE DIALOG 

 

Capture Google Earth image 

The Capture Google Earth image is used to capture the terrain and imagery of the current Google Earth view. 
Terrain imagery is captured as a mesh or a B-spline surface, with the image attached to it as a material. The 
captured image will be at screen resolution and in monochrome (a Google Earth restriction). 

mk:@MSITStore:C:\Program%20Files%20(x86)\Bentley\MicroStation%20V8i%20(SELECTseries)\Documentation\MicroStation.chm::/ustnhelp1329.html
mk:@MSITStore:C:\Program%20Files%20(x86)\Bentley\MicroStation%20V8i%20(SELECTseries)\Documentation\MicroStation.chm::/ustnhelp1329.html
mk:@MSITStore:C:\Program%20Files%20(x86)\Bentley\MicroStation%20V8i%20(SELECTseries)\Documentation\MicroStation.chm::/ustnhelp1330.html#P2E14F
mk:@MSITStore:C:\Program%20Files%20(x86)\Bentley\MicroStation%20V8i%20(SELECTseries)\Documentation\MicroStation.chm::/ustnhelp1331.html#P2F8F9
mk:@MSITStore:C:\Program%20Files%20(x86)\Bentley\MicroStation%20V8i%20(SELECTseries)\Documentation\MicroStation.chm::/ustnhelp1346.html#P268D1
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If there is no information about the location of the model, MicroStation assumes that your model´s origin 
coincides with the center of your Google Earth view and that your model´s Y-axis is to be aligned with north. If 
location information is present in the model then MicroStation uses the transform derived from it. 

You can maintain your Google Earth view perspective on capture by checking the `Use Google Earth View to 
Determine Rotation´ setting in the Google Earth Tools Settings dialog. 

When capturing a view: 

• For best results, the Google Earth view should have the camera pointing straight down. 
• In order to capture terrain, the Terrain layer must be enabled in Google Earth. 

Prior to capturing an image, it may be necessary to configure Google Earth as follows:  

• In the View pane of the Google Earth Options window, set Detail Area to “Large 1024x1024” and 
Graphics Mode to “DirectX”. 

• Resize the Google Earth application window to the size of the graphics image desired. 

 

Hints, Tips & Tricks: 
• Google Earth Image (.jpg) is a MicroStation element and is placed on the active level 
• In order to capture terrain, the Terrain layer must be enabled in Google Earth. 
• The boundary, or perimeter, of a 3D Google Earth image will appear warped.  If a simple shape is 

desired, it is recommended to create a large image in a .dgn, and reference>clip the file. 
• To get a color image, go to Google Earth while the correct view is still in place, and select 

File>Save>Save Image and overwrite the existing .jpg. 
• To correct when an element or reference is hidden by the image: 

o If a reference file is not visible, and in a 3D drawing:  Open the reference file dialog and add an 
elevation or “Z” value to the reference file to raise it above the image. 

o If a MicroStation element is not visible, select the element, select the change attributes 
command, and “add” to the priority of the element. 

• The MicroStation file (.dgn) with the inserted image, and the image file (.jpg) must remain in the same 
directory or the association is lost. 

• Recommended Procedure:  Place a Google Earth Image (.jpeg) into a MicroStation “Image” file.  Then 
use the MicroStation (.dgn) as a referenced file within a “Motif”. 

o Doing this enables easier and better “clipping” of the image, because the user is clipping a 
reference file instead of an image. 
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SAMPLE  PROCEDURE (1) - IMPORTING GOOGLE EARTH IMAGES IN 
2D OR 3D 

Description:  This sample procedure will demonstrate the process of importing a Google Earth image 
into MicroStation 2D files or with optional 3D terrain visualization. 

Preliminary Steps 
1. Download from the cflhd.gov website, or Copy directory K:\CADD Coordinator\4A_Training & 

Presentations\CRAM Sessions\CRAM_38 to your local C:\CADD\ CRAM_Sessions\ directory. 
2. Open MicroStation in an English workspace.  Open MicroStation File => C:\CADD\CRAM 

Sessions\CRAM_38-(GoogleEarthImages)\ IMG(Sample)CRAM_3D.dgn 
 

Note the MicroStation file used must be a 3D file if vertical visualizations are desired. 
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Procedure Steps 

1. Select and set the Geographic Coordinate System:   
1.1. Determine the site’s geographic location/coordinate system:  This may already be known by the 

CFLHD Survey group.  First inquire with the project’s Cross Functional Team (CFT) representative in 
the Survey group.  If the correct coordinate system is not known, a Google search can typically help 
with the correct determination.  Google “project state + state plane zones + map”.  For the example 
CRAM use “California state plane zones map” This example will use CA Zone 3. 
 

 
 

1.2. Set the Geographic Coordinate System within MicroStation: 
1.2.1. From the Geographic Toolbox, chose Select Geographic Coordinate System, and then From 

Library. 
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

 
 

1.2.2. Navigate to Projected>North America> United States of America> California, and Select the 
NAD83, Zone 3 in (ft US) units.  Select Ok. 

 
 

  



CADD REHERSALS ANYTIME-WITH MICROSTATION&GEOPAK (CRAM) 
CRAM #38 – Google Earth Images 

4/16/2012 

 - 8 - 

2. Google Earth Steps – Image Settings: 
2.1. Start Google Earth, and fit the view to the area for the image capture. 

2.1.1. An optional, “short cut” method is to use the Synchronize Google Earth View tool on the 
Geographic toolbox. 

 
 

2.2. Toggle the desired “Layers” within Google Earth.  Below are recommendations: 
• All off, except 
• Roads – on 
• Borders and Labels - on 
• Terrain – on (optional for 3D visualizations) 
 

3. MicroStation Import Steps - Follow and “Capture” the image from Google Earth: 
3.1. Set the appropriate “attributes” for the image to be placed with 

3.1.1. A Google Earth image becomes a MicroStation element and is placed with the “active” 
attributes.  Set the attributes to: Level = Aux_01, and all else to “by level”. 

 
 

3.2. On the Geographic toolbox, select the Follow Google Earth View. 

 
 

3.3. On the Geographic toolbox, select the Capture Google Earth Image. 

 
 

3.3.1. Then, select a data point anywhere in the MicroStation view.  After some processing (dependant 
on the size of the image), a “wireframe” image will appear.  A .jpeg format image will have been 
created and placed in the same location as the MicroStation file (.dgn).  The image name will be 
“MicrostationFileName+TerrainCapture1.jpg” or 
IMG(Sample)CRAM_3DTerrainCapture1.jpg. 

3.3.2. For a color image: Back in Google Earth, select File>Save>SaveImage, choose a resolution, and 
overwrite the image created to get a color image.  This may take a minute. 

3.3.3. Reload the MicroStation file (.dgn), and the image will now be in color.  
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4. Additional MicroStation Steps, Settings and Sheet Finalization: 
4.1. Image sequencing or “prioritization”:  Sometimes a Google Earth Image will appear “on top” of 

another MicroStation element or reference file.  This can be corrected.  
• If a reference file is not visible, and in a 3D drawing:  Open the reference file dialog and add an 

elevation or “Z” value to the reference file to raise it above the image. 
• If a MicroStation element is not visible, select the element, select the change attributes 

command, and “add” to the priority of the element. 
4.1.1. Exercise:  Open the “Motif” MicroStation file \CRAM_38-(GoogleEarthImages)\ 

MTF(Sample)CRAM_3D.dgn.  There are two “Alignment” files referenced in, but are not visible 
where the image is located.  Open the Reference Dialog, select each “ALI” reference file, and 
change the “Z” value for the reference files to 1000. 

 
 

4.2. Reference File “Presentation” setting: When a “parent” file’s Display Style is set to Smooth, and a 
CFL Border Sheet file is reference, the border’s appearance can be incorrect.  This can be corrected by 
changing the reference file’s “presentation” setting to wireframe. 

4.2.1. Exercise:  Open the “Image” MicroStation file \CRAM_38-(GoogleEarthImages)\ 
IMG(Sample)CRAM_3Dtest.dgn.  Note the opaque attributes of the Border reference.   
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4.2.2. Open the Reference Dialog, and select the border file BDR(Sample)CRAM.dgn. Then, select the 
Set Reference Presentation icon. 
 

 
 

4.2.3. From the Reference Presentation dialog, change the “Display Style” to Wireframe. 
 

 
 

4.3. Image file referencing:  Some modifications may be necessary when referencing in a file with an 
inserted Google Earth Image.  The FLH default view attributes setting for Display Style is Wireframe. 

4.3.1. Similar to the steps in 4.2 above, open the “Motif” MicroStation file \CRAM_38-
(GoogleEarthImages)\MTF(Sample)CRAM_3Dtest.dgn. 

4.3.1.1. From the Reference Presentation dialog, Select the “IMG” file, and the “Display Style” 
to Smooth. 

4.4.  Challenge Exercise:  Open the “Site Plan” MicroStation sheet file \CRAM_38-
(GoogleEarthImages)\STE(Sample)CRAM_3D.dgn. 

4.4.1. Use the “Motif” file to set the background image and design for a 1”=500’ Site Map. 
4.4.2. Hint:  There are models in the “Motif” file.  See Post Exercise Files for end results. 
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