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Chapter 10 Batch Printing 
About Batch Printing (For CFLHD employees) 
Batch printing is a MicroStation utility used to print and re-print sets of 
drawings.  Job sets are created containing the desired drawing files and a set 
of print specifications are created for each job set.  The print specifications are 
defined containing information such as printer, print area, layout, and display.  
This chapter will detail each of the necessary settings associated with Batch 
Printing. 

For Consultants, see “General Batch Printing Information” at the following link: 
http://www.cflhd.gov/cadd/CaddManDocs/Chapter10_v8.pdf 

 

Workflow 1:  Accessing Batch Printing 
1. CFL employees can run CFL Plot Utility VBA by Key-in:  vba run CFLplot.  

CFL Plot Utility will now be accessible.  
2. Select the Design Group, and then select the Batch Plot button. 
3. Select Batch Plot 11x17 to Batch print plan sheets and cross section 

sheets. 
 

 

Figure 10-1:  X30 Plot Utility- Batch Plot 

4. Once selected, the Batch Print dialog box is activated as shown below.  
The top bar on this dialog will show the current Job Set.  Shown below as 
[Untitled].  Once a new Job Set is created or an existing Job Set is 
opened the name will replace [untitled]. 

 

http://www.cflhd.gov/cadd/CaddManDocs/Chapter10_v8.pdf�
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Figure 10-2:  Batch Print 

5. To open an existing job set select File>Open and select the desired job. 

Job Sets 
Job Sets are lists of files to be printed, along with the associated print 
specifications used to print the files; such as which printer, what area to print, 
what scale, which pen table, etc.  Each job set created will have the extension, 
.job. 

Workflow 2:  Creating a New Job Set 
1. The user must first select the design files to be added to the Job Set.  

Select Edit>Add Files or select the Add Design Files icon, as shown 
below. 

 

 

Figure 10-3:  Add Files icon 
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2. Once selected the following dialog box will activate. 

 

Figure 10-4:  Select Files to Add 

3. Select the desired directory from the upper right Directories box.  Once 
you have navigated to the correct directory, select the desired files from 
the upper left Files box.  You may select multiple files by using the 
control or shift keys while selecting. 

4. After selecting the desired files, the Add button will be active.  Select the 
Add button and the selected files will be populated in the selected files 
box at the bottom of the dialog box. 

5. Once complete, select the Done button. 
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Figure 10-5:  Files/Models Added to Job Set 

6. Standard drawings and Details have multiple models. You will need to 
select the “Graphics” and either the “Metric” or “US Customary” models 
and delete them from the list so that only the needed model is plotted. 
Once the files to be batch printed are selected, you can set the plot 
specifications.  These specifications tell MicroStation how to plot the 
selected files. 

 
 
 
 
7. Select Specifications>Manage, or select the Manage Specification icon, 

as shown below. 

 

Figure 10-6:  Manage Specifications Icon 

It is possible to change the default settings for all models 
to be added to plot jobs.  Within the Microstation 
Configuration settings, changing the configuration 
variable MS_BATCHPRINT_ADD_ALL_MODELS to “0” 
will not add multiple entries.  The default is “1”. 
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8. Once selected the following dialog box will activate. 

 

Figure 10-7:  Batch Print Specification Manager - Printer 

9. Select the appropriate printer from the right hand box. 
10. From the Batch Print Specification Manager dialog box select Print Area. 
 

 

Figure 10-8:  Batch Print Specification Manager - Print Area 

11. The “Print Area” properties dialog box, shown above, is set for the 
plotshape level in the FLH_Combined.dgnlib library. 
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12. From the Batch Print Specification Manager dialog box select Layout. 
 

 

Figure 10-9:  Batch Print Specification Manager - Layout 

13. Select “V8_X30” from the right hand box.  No changes to the properties 
are required. 

14. From the Batch Print Specification Manager dialog box select Display. 
 

 

Figure 10-10:  Batch Print Specification Manager - Display 

15. Select either “V8_X30 Black & White” or “V8_X30 Color” from the right 
hand box depending on whether you are plotting Black & White or Color. 

16. Close the Batch Print Specification Manager by selecting the X in the 
upper right corner. 

17. Once the files have been added and the specifications set, select 
File>Save.  This will save all of the settings in a Job Set file with a .job 
extension.  Job Set files should be stored in your project directory.  There 
is no standard or default directory where batch print looks for these files. 
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Workflow 3:  Printing 
1. If reprinting a previously saved Batch Print Job Set use File>Open in the 

main Batch Print dialog pull down menus to select the .job file for that 
Job Set.  This will populate the dialog with the files to be printed and the 
associated print specifications.  If continuing directly from Workflow 2 
above (Creating a New Job Set) then skip this step. 

2. From the Batch Print dialog, shown below, select the printer icon. 

 

Figure 10-11:  Batch Print  

3. The Print Batch dialog will activate. 

 

Figure 10-12:  Print Batch 

4. From this dialog box the user can select a print range, log file, and setup 
the system printer. 

 
 
 

The Set Up System Printer button will take you to the 
standard windows printer dialog.  This should not need to 
be done at this point. 
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5. Select OK and the files will be sent to the printer.  A status bar will be 

displayed during the process, as shown below. 

 

CFL Internal Plotting 
At CFL there are several combinations of plot drivers and pen tables for both 
11x17 and 8 ½ x 11 and for both color and black and white.  Listed in the 
tables below are the plot drivers (.plt), the pen tables (.tbl) that are 
automatically attached, and the output produced for each combination. 

11"x17" Black-and-White Sheets 
Printer:  HP5200 LaserJet printers located in design areas 
Plot driver files location:   
N:\Standards\V8_RESOURCE\X_30\Plotting\PrintPlot\plotdrv\plotdrv_
ad?\*.plt 
Pen tables:  Appropriate pen table is automatically attached when the 
user selects the plotter driver file. 
 

Plot Driver Pen Table (Attached Automatically) 
Description 

HP5200_11x17_Landscape.plt HP5200_X30.tbl 
Landscape orientation 11"x17".  Fades the P&P and XS sheet grid (co=238 and/or co=160) and everything on 
levels E_*.  All other elements are plotted with color = black.  Adds file name/date/time stamp at lower left edge of 
sheet border. 

HP5200_11x17_Portrait.plt HP5200_X30.tbl 
Portrait orientation 11"x17".  Fades the P&P and XS sheet grid (co=238 and/or co=160) and everything on levels 
E_*.  All other elements are plotted with color = black.  Adds file name/date/time stamp at lower left edge of sheet 
border. 

8½ x11 Black-and-White Sheets 
Printer:  HP5200 LaserJet printers located in design areas 
Plot driver files location:   
N:\Standards\V8_RESOURCE\X_30\Plotting\PrintPlot\plotdrv\plotdrv_
ad?\*.plt 
Pen tables:  Appropriate pen table is automatically attached when the 
user selects the plotter driver file. 

 
Plot Driver Pen Table (Attached Automatically) 

Description 
HP5200_Letter_Landscape.plt HP5200_X30.tbl 

Landscape orientation 8 ½”x11”.  Fades the P&P and XS sheet grid (co=238 and/or co=160) and everything on 
levels E_*.  All other elements are plotted with color = black.  Adds file name/date/time stamp at lower left edge of 
sheet border. 

HP5200_Letter_Portrait.plt HP5200_X30.tbl 
Portrait orientation 8 ½” x11".  Fades the P&P and XS sheet grid (co=238 and/or co=160) and everything on 
levels E_*.  All other elements are plotted with color = black.  Adds file name/date/time stamp at lower left edge of 
sheet border. 
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11"x17" Color Sheets 
Printer:  CFLDesignColor (HP5550 LaserJet printer) located in plotter 
room. 
Plot driver files location:   
N:\Standards\V8_RESOURCE\X_30\Plotting\PrintPlot\plotdrv\plotdrv_
ad?\*.plt 
Pen tables:  Appropriate pen table is automatically attached when the 
user selects the plotter driver file. 
 

Plot Driver Pen Table (Attached Automatically) 
Description 

CflDesignColor_11x17_Landscape.plt HP5550_color_X30.tbl 
Landscape orientation 11"x17".  Plots all elements with color shown on screen except black screen 
background changed to white background in plot.  Adds file name/date/time stamp at lower left edge 
of sheet border. [Orientation can be changed from Landscape to Portrait] 

Wide Format Color Plots (up to 21.306" x 33.276") 
Printer:  HP5500 DesignJet plotter located in plotter room. 
Plot driver files location:   
N:\Standards\V8_RESOURCE\X_30\Plotting\PrintPlot\plotdrv\Xerox_H
P5500\*.plt 
Pen tables:  Appropriate pen table is automatically attached when the 
user selects the plotter driver file. 
 

Plot Driver Pen Table (Attached Automatically) 
Description 

HP5500_X30_BW.plt HP5500_X30.tbl 
Roll plots up to 21.306"x33.276" (Exact size of Border).  Fades the P&P and XS sheet grid (co=238 and/or 
co=160) and everything on levels E_*.  All other elements are plotted with color = black.   Adds file 
name/date/time stamp at lower left edge of sheet border (if any). [Prints to scale when plot is maximized] 

HP5500_X30_WYSIWYG.plt Color_WYSIWYG_X30.tbl 
Roll plots up to 21.306"x33.276" (Exact size of Border).  Plots all elements with color shown on screen except 
black screen background changed to white background in plot.  Adds file name/date/time stamp at lower left edge 
of sheet border (if any). [Prints to scale when plot is maximized 

 

Wide Format B/W Plots (up to 36" x 120”) 
Printer:  Xerox 510 plotter located in plotter room. 
Plot driver files location:   
N:\Standards\V8_RESOURCE\X_30\Plotting\PrintPlot\plotdrv\Xerox_H
P5500\*.plt 
Pen tables:  Appropriate pen table is automatically attached when the 
user selects the plotter driver file. 
 

Plot Driver Pen Table (Attached Automatically) 
Description 

XEROX510.plt XEROX510_X30.tbl 
Roll plots up to 36”x120”.  Fades the P&P and XS sheet grid (co=238 and/or co=160) and everything on levels 
E_*.  All other elements are plotted with color = black.   Adds file name/date/time stamp at lower left edge of sheet 
border (if any).  
Choose Papersize 
Size: “D_Size” 21.306"x33.276" (Exact size of Border) [Prints to scale when plot is maximized] 
Size: “Oversize_X10” [Prints up to 36”x120”] 
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11"x17" B/W or Color PDF Sheets 
Printer:  No Physical Printer 
Plot driver files location:   
N:\Standards\V8_RESOURCE\X_30\Plotting\PrintPlot\plotdrv\PDF\*.plt 
Pen tables:  Appropriate pen table is automatically attached when the 
user selects the plotter driver file. 
 

Plot Driver Pen Table (Attached Automatically) 
Description 

HP5200_11x17_Landscape_no_shade_pdf.plt HP5200_X30.tbl 
Landscape orientation 11"x17".  Fades the P&P and XS sheet grid (co=238 and/or co=160) and everything on 
levels E_*.  All other elements are plotted with color = black.  Adds file name/date/time stamp at lower left edge of 
sheet border. 

HP5200_11x17_Portrait_no_shade_pdf.plt HP5200_X30.tbl 
Portrait orientation 11"x17".  Fades the P&P and XS sheet grid (co=238 and/or co=160) and everything on levels 
E_*.  All other elements are plotted with color = black.  Adds file name/date/time stamp at lower left edge of sheet 
border. 

Color_11x17_Landscape_pdf.plt HP5550_color_X30.tbl 
Landscape orientation 11"x17".  Plots all elements with color shown on screen except black screen background 
changed to white background in plot.  Adds file name/date/time stamp at lower left edge of sheet border. 

Color_11x17_Portrait_pdf.plt HP5550_color_X30.tbl 
Portrait orientation 11"x17".  Plots all elements with color shown on screen except black screen background 
changed to white background in plot.  Adds file name/date/time stamp at lower left edge of sheet border. 

 
 

Workflow 4:  Batch Plotting PDFs  
About PDFs 
PDF files are the new standard for presenting final plans to contractors for 
bidding purposes.  At the completion of the design for all projects it is required 
to generate PDF files for each final plan sheet.  It is also imperative that the 
name of the PDF files match the sheet names within the plans.  For Example:  
the first sheet for Roadway Plan & Profiles sheet (C-ML_P&P) would have a 
PDF file named C001.pdf.  The workflow below explains how to automate this 
process.  This process can be a big time saver when creating PDFs for cross 
sections. 

1. First open or create a Batch Plot PDF job (.job) as explained in workflow 2 
of this document.  Make sure that the .dgn files are listed in plan sheet 
order within the plot job.  Move files that are out of sequence by dragging 
and dropping them in the correct position.  Or, you may select Edit>Move 
Files… within the Batch Plot dialog.  It is possible to move multiple files 
at once.  
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Figure 10-13:  Print Batch Sequencing 

2. Highlight Printer within the Specifications Controlling Printing window 
and then select the Specifications Properties icon.  

 

Figure 10-14:  Printer Specifications Properties 

3. Set the correct printer driver, paper size and orientation for the desired 
output. 

4. Within the Output and Post Processing settings, ensure that the Print to: 
File option is selected.  

5. Unselect the Print document set to single file option. 
6. Browse and select the directory that the PDF files will be placed.  
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Figure 10-15:  PDF Print Properties 

7. The Print Cmd: settings are to establish the naming convention for the 
PDF files.  Options for the naming strings are as follows: 
• Normal character:  for example “C” will place a “C” in the name of the 

PDF files generated 
• %b:  inserts a boundary counter that starts at 001 for all print 

boundaries within the specified .dgn files.  (This typically works for 
multiple .dgn files, but has a potential for resetting the counter to 001 
for each individual .dgn in the plot job.)  If used, verify your PDF files 
are correctly numbered. 

• %e:  inserts the file extension into the name. 
• %j:  inserts the name of the Batch Plot (.job) into the PDF name. 
• %p:  Inserts a plan sheet counter starting at 001 and is continuous for 

multiple .dgn files in the plot job (preferred method). 
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The advisable method for CFL projects is indicated above in Figure 10-15.  
The “X” represents the alphanumeric sheet number in the plans.  In this 
example, it is for a Mainline Cross Section sheet.  The resulting PDF names 
would be X001.pdf, X002.pdf, X003.pdf… 

 

Figure 10-16:  Print Filename Format 

To set the Print Cmd, select the Name button.  Select “Custom” for the format 
options.  Use “pdf” for the Extension.  Then for the string code use 
“Alphanumeric letter”%p.%e.  Verify the naming output per the Samples: line. 
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